Changes between Version 2 and Version 3 of WikiStart


Ignore:
Timestamp:
Jul 11, 2010, 11:00:46 AM (11 years ago)
Author:
Kris Deugau
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WikiStart

    v2 v3  
    3636
    3737- Perl
    38   - NetAddr::IP.  I would not recommend using anything older than 4.x;  however it should work well enough with 3.x.
     38  - NetAddr::IP >= 4.x.  3.x may work, however 4.x has been current on all of my development platforms for more than 5 years.
    3939  - CGI::Carp
    4040  - DBI
     
    4343  - Sys::!SigAction.  This isn't strictly required;  it's used in an example hook for validating customer IDs against an external database.
    4444  - Sys::Syslog
    45 - PostgreSQL v7.4 or higher.  Postgres provides an IP address/IP netblock data type, and operators to match;  much of the functionality relies on these database operations.  Other database engines could be used, with variying degress of trouble and hackery.  v8.x is probably a good idea since 7.x is no longer supported upstream.
     45- PostgreSQL v7.4 or higher.  Postgres provides an IP address/IP netblock data type, and operators to match;  much of the functionality relies on these database operations.  Other database engines could be used, with varying degress of trouble and hackery.  v8.x is probably a good idea since 7.x is no longer supported upstream.
    4646- Webserver supporting CGI executables.  Note that the current code is somewhat inflexible about its web path, but that's due to be fixed (see #3, #15, and #17).
    4747